The only system requirement for MobyMax is an internet connection and browser.  The browser versions we support are:

  • Internet Explorer 11 or higher
  • Firefox 26 or higher
  • Safari 7.0.6 or higher
  • Chrome 32 or higher


No download is required for MobyMax. MobyMax is designed to work in very low bandwidth environments and will have very little impact on your network. For example, a student only downloads 1 MB of data in 5 minutes typically.